ファイル
各プロジェクトには「ファイル」タブがあり、プロジェクトに関連する書類(技術仕様書、契約書、現地写真、系統連系の申請書類など)をまとめて保管できます。ファイルはフォルダの代わりにタグで整理するため、1つのファイルを複数のカテゴリに分類できます。ファイルはダウンロードせずに絞り込み、グループ化、検索、プレビューできます。
ファイルタブを開くには、プロジェクト一覧からプロジェクトを選択し、プロジェクト画面の最後のタブにある「ファイル」を選択します。
ファイルのアップロード
ファイルタブ上部の「アップロード」をクリックし、ファイルをアップロードエリアにドラッグするか、参照して選択します。ファイルをファイル一覧に直接ドラッグしてアップロードを開始することもできます。1ファイルあたり最大500 MB、一度に最大100ファイルまでアップロードできます。
「アップロード」ダイアログからアップロードするファイルが、プロジェクトに既に存在するファイルと同じ名前の場合は、既存のファイルを上書きするかどうかの確認が表示されます。ファイル一覧に直接ドラッグしたファイルが既存のファイルと同じ名前の場合はアップロードされないため、置き換えるには「アップロード」を使用してください。各ファイルには、アップロードした人と日時が表示されます。
タグによるファイルの整理
各ファイルには1つ以上のタグを付けられるため、1つの書類を同時に複数のカテゴリに分類でき、タグでグループ化するとそれぞれのタグの下に表示されます。タグは「タグ」列に色付きのチップとして表示され、チップをクリックすると、そのタグが付いたファイルだけに一覧を絞り込めます。
ファイルのタグは、プロジェクト一覧で使うタグ(プロジェクトのタグ)とは別の、ワークスペースのファイル用タグライブラリから選びます。そのため、ファイル用に作成したタグはプロジェクトのタグ選択に表示されず、その逆も同様です。ファイルのタグの名前や色の変更、削除は、タグ管理の「ファイル」タブで行います。
1つのファイルにタグを付ける
1つのファイルには、次の2か所からタグを付けられます。
- ファイル一覧で、対象ファイルの行末にあるアクションメニュー(⋯)を開き、「タグを編集」を選択します。
- ファイル詳細パネルで、ファイル情報の下にあるタグ編集欄を使用します。
いずれの場合も、既存のタグから選ぶか、新しい名前を入力してその場でタグを作成できます。新しく作成したタグはワークスペースのファイル用タグライブラリに追加され、チーム内で再利用できます。
複数のファイルにまとめてタグを付ける
ファイル一覧のチェックボックスで対象を選択します。画面下部に表示されるメニューで「タグを編集」をクリックすると、選択したすべてのファイルに対して一度にタグを追加・削除できます。
ファイルタグの例
ファイルタグはあらかじめ用意されておらず、ご自身で作成します。1つのファイルに複数のタグを付けられるため、1つの書類をいくつかの観点から分類できます。たとえばパワーコンディショナの仕様書にはtype/仕様書と機器/パワコンの両方を付けられ、書類の種類でグループ化しても機器でグループ化しても表示されます。type/や機器/のような接頭辞を使うと、関連するタグをまとめられます。まずは少数のタグから始め、必要に応じて追加してください。
絞り込みとグループ化
検索
タブ上部の検索ボックスを使うと、入力に応じてファイル名で一覧を絞り込めます。
絞り込み
「絞込み」をクリックすると絞り込みパネルが開き、次の条件を組み合わせて指定できます。
- タグで絞り込む:選択したタグが付いたファイルのみを表示します。複数のタグを選択した場合は、そのいずれかのタグが付いたファイルが表示されます。
- ファイル形式:拡張子に基づく区分(画像、文書、動画、圧縮ファイル、その他)。
- アップロード日時:アップロードされた日付の範囲。
- アップロード者:ファイルをアップロードしたワークスペースのメンバー。
- サイズ:ファイルサイズの範囲(0から50 MB以上まで)。
絞り込みパネルには、該当するファイル数と全体のファイル数が表示されます。一覧内のタグチップをクリックしても、そのタグが絞り込み条件に追加されます。
グループ化
「表示」メニューを開くと一覧をグループ化できます。初期状態ではタグでグループ化されており、各タグが見出しになります。複数のタグが付いたファイルはそれぞれのタグの下に表示され、タグが付いていないファイルは末尾の「タグなし」グループにまとめられます。「アップロード者でグループ化」に切り替えることも、「グループなし」を選んで1つのフラットな一覧として表示することもできます。
並び替えと列
一覧は、グループ化の有無にかかわらず、アップロード日時の新しい順に並びます。列見出し(「ファイル名」「アップロード日時」「アップロード者」「サイズ」)をクリックすると、その項目で並び替えられます。「表示」メニューでは、表示する列を選ぶこともできます(ファイル名は常に表示されます)。
ファイルのプレビュー
ファイルをクリックすると、右側に「ファイル詳細」パネルが開きます。右上のパネル切り替えボタンで、いつでも表示・非表示を切り替えられます。パネルには、ファイル名、アップロード日時、アップロード者、サイズ、「ダウンロード」リンク、ファイルのタグ、ファイルのプレビューが表示されます。
PDFと画像(PNG、JPG、JPEG、GIF、WebP、SVG)はパネル内で直接プレビューできます。「拡大表示」をクリックする(または画像をクリックする)と、プレビューが全画面で開きます。閉じるボタンをクリックするか、プレビューの外側をクリックすると元に戻ります。PDFはブラウザ標準のPDFビューアーで表示されるため、パスワードで保護されたPDFはそこでパスワードを入力します。ダウンロードして開くこともできます。
一部のファイルはパネル内ではプレビューできません。
- その他のファイル形式(ExcelやWordの文書など)には「プレビューに対応していません」と表示されます。適切なアプリケーションで開くには、ダウンロードしてください。
- 50 MBを超えるファイルには「プレビュー上限を超えています」と表示されます。ほかのファイルと同様に保存されており、ダウンロードすれば表示できます。
ファイルのダウンロードと共有
1つのファイルをダウンロードするには、対象の行のアクションメニュー(⋯)を開いて「ダウンロード」を選択するか、ファイル詳細パネルの「ダウンロード」リンクを使用します。チームのメンバーとファイルを共有するには、同じメニューから「リンクをコピー」を選択します。
複数のファイルをまとめてダウンロードするには、チェックボックスで対象を選択し、画面下部のメニューで「ダウンロード」をクリックします。選択したファイルは1つのZIPファイルとしてダウンロードされ、1回に含められるのは最大50ファイル、合計100 MBまでです。アップロード中のファイルは除外されます。
ファイルの削除
ファイルを削除するには、対象の行のアクションメニュー(⋯)を開いて「削除」を選択するか、複数のファイルを選択して画面下部のメニューで「削除」をクリックします。削除は元に戻せないため、ファイルが削除される前に確認チェックボックスへのチェックが求められます。